Назначение.

Программный продукт NDemia CashMatic KioskBrowser разработан как основа для создания клиентских интерфейсов терминалов и киосков, оснащённых специализированным оборудованием для приёма и оформления платежей наличными денежными средствами (купюроприёмник, фискальный регистратор, чековый принтер и т.п.)
Пользовательский интерфейс NDemia CashMatic KioskBrowser реализован как специализированная оболочка для Microsoft Internet Explorer/Windows Internet Explorer и, соответственно, включает в себя всю функциональность, предоставляемую разработчикам веб-приложений Internet Explorer, в том числе поддержку ActiveX, javascript, Visual Basic Script.
NDemia CashMatic KioskBrowser предлагает определённую объектную модель приёма платежа, приспособленную для разработчика платёжного интерфейса, и в то же время позволяющую широко использовать возможности специализированного оборудования терминала.
Задача разработки платёжного интерфейса при помощи NDemia CashMatic KioskBrowser сводится к достаточно традиционному веб-дизайну. Разработчик освобождается от необходимости знания конкретики работы оборудования терминала, и вместе с тем значительно снижается зависимость разрабатываемого веб-приложения от состава, моделей и протоколов управления этого оборудования.
Программный продукт NDemia CashMatic KioskBrowser разработан с учётом опыта создания и успешного внедрения целого ряда небольших платёжных систем, на один или несколько терминалов. Все типичные задачи и проблемы, с которыми обычно сталкивается разработчик таких решений, сведены в этом программном продукте к нескольким объектам с небольшим числом свойств и методов. При этом разработчик сразу, с самого начала разработки, видит полный спектр задач платёжной системы, какой бы она ни была: приём наличных, регистрация платежа, печать выходных документов, обработка отказов оборудования и т.п.
NDemia CashMatic KioskBrowser полностью открыт для интеграции с другим программным обеспечением - объектная модель предусматривает возможность подключения стороннего кода и поддерживает механизм компонентов расширения (плагинов).


Возможности.

Логическая интеграция оборудования Организация платёжного сеанса Настройка пользовательского интерфейса Контекст терминала Постоянный мониторинг оборудования Обработка отказов Обработка инкассации Счётчик купюр Ограничение просмотра веб-контента Шаблоны печати Звуковая поддержка Отладочные средства и симуляция Возможность использования службы NDemia CashMatic Kiosk Подключение компонентов расширения (плагинов) Обновление продукта Испытательный срок


Логическая интеграция оборудования.

NDemia CashMatic KioskBrowser позволяет разработчику платёжной системы рассматривать весь терминал как целостное устройство. Таким образом упрощается задача отслеживания и взаимного увязывания текущих состояний специального оборудования.


Организация платёжного сеанса.

NDemia CashMatic KioskBrowser не просто поддерживает работу купюроприёмника, но и даёт готовое решение организации приёма наличных как процедурного сеанса: выделяются начальное исходное состояние, приём купюры, переход к приёму следующей купюры, завершение приёма, прерывание приёма по таймауту неактивности пользователя или по отказу оборудования, и т.п.


Настройка пользовательского интерфейса.

NDemia CashMatic KioskBrowser предоставляет прикладному программисту и владельцу терминала ряд возможностей по настройке работы пользовательского интерфейса (автозапуск, использование звуковых сообщений, отключение курсора мыши для сенсорных экранов, и т.п., вплоть до запуска пользовательского интерфейса на отдельном рабочем столе, что полностью изолирует экран от любых сообщений других программ и операционной системы)


Контекст терминала.

NDemia CashMatic KioskBrowser разделяет задачи, связанные с обслуживанием очередного пользователя, и задачи, связанные с работой терминала в целом (от включения до выключения).


Постоянный мониторинг оборудования.

NDemia CashMatic KioskBrowser выполняет постоянный мониторинг состояния специального оборудования терминала. Таким образом, разработчик платёжной системы освобождается не только от необходимости знать и учитывать специфику работы конкретного оборудования, но и от увязывания мониторинга с выполнением основной задачи - обслуживания пользователей.


Обработка отказов.

NDemia CashMatic KioskBrowser предоставляет разработчику платёжной системы готовое единое решение по реакции платёжного интерфейса на любой отказ оборудования и затем на восстановление работоспособности терминала.


Обработка инкассации.

NDemia CashMatic KioskBrowser узнаёт о снятии стекера с купюроприёмника и оповещает об этом компоненты расширения. При снятом стекере веб-приложению разрешены переходы только на страницу обработки инкассации.


Счётчик купюр.

NDemia CashMatic KioskBrowser имеет собственный счётчик принятых купюр (отдельно от купюроприёмника), записываемый в системном реестре Windows и сбрасываемый при инкассации.


Ограничение просмотра веб-контента.

NDemia CashMatic KioskBrowser организует порядок просмотра веб-контента более жёстко, чем обычные веб-браузеры, ограничивая возможные действия пользователя по управлению навигацией, а также выполняя переходы на фиксированные адреса при определённых сигналах от специального оборудования. Вместе с тем разработчику платёжной системы предоставляются дополнительные возможности по организации сеанса работы пользователя на клиентской стороне, что уменьшает зависимость работы пользовательского интерфейса от стабильности связи с сервером и сокращает дополнительный трафик, несущественный с точки зрения конечного результата. Управление сценарием приёма платежа на клиентской стороне является положительным моментом и с точки зрения информационной безопасности - уменьшается количество закрытых данных, которые требуется передавать по каналам связи.


Шаблоны печати.

NDemia CashMatic KioskBrowser предоставляет разработчику платёжной системы средства, позволяющие абстрагироваться от конкретики применяемого на терминале печатающего устройства - это может быть чековый принтер, фискальный регистратор и даже просто текстовый файл. Форматирование документа (т.е. что, где и как должно быть конкретно напечатано) задаётся шаблоном печати. Шаблоны печати могут легко редактироваться в текстовом формате, без изменения прикладной программы. Шаблоны печати могут различаться на разных терминалах, работающих в одной платёжной системе, и эти различия будут почти полностью скрыты от прикладного скрипта. Это повышает универсальность скриптов прикладного разработчика, одновременно предоставляя довольно большую гибкость в настройке чека на конкретном оборудовании


Звуковая поддержка.

NDemia CashMatic KioskBrowser предоставляет разработчику платёжной системы возможность вопроизведения звуковых фонограмм в контексте хост-приложения (в дополнение к имеющимся в Internet Explorer средствам озвучивания HTML-документов), звук может воспроизводиться как при переходе со страницы на страницу, так и вообще безотносительно навигации. Кроме того, предоставляется возможность автоматизированного программного монтажа фонограмм (комбинирование голосовых фраз из звукозаписей отдельных словосочетаний и слов, включая готовое решение для озвучивания чисел (от 0 до 999 999 999 999), в частности денежных сумм).


Отладочные средства и симуляция.

NDemia CashMatic KioskBrowser может использоваться не только на платёжном терминале, но и на обычном компьютере, без подключения купюроприёмника. В этом случае в распоряжении разработчика платёжного интерфейса имеются средства симуляции ввода купюр, а также средства, имитирующие другие события купюроприёмника (для отладки реакций прикладной системы на снятие и восстановление стекера, переполнение купюроприёмника и другие отказы оборудования).


Возможность использования службы NDemia CashMatic Kiosk.

Одной из возможностей, предоставляемых программным продуктом прикладному программисту, является прямое использование резидентной службы NDemia CashMatic Kiosk. Данная служба обеспечивает единого контекста управления оборудованием платёжного киоска, включая поддержку купюроприёмника, чекового принтера, звуковой поток и т.п. (за исключением фискального регистратора). В стандартную комплектацию продукта включён ряд дополнительных маленьких программ, выполняющих взаимодействие со службой (т.н. интерфейсных команд), которые могут вызываться из любых приложений - не только NDemia CashMatic KioskBrowser, но и любых Windows-приложений, способных запускать внешние процессы. Например, можно организовать платёжный интерфейс на основе Microsoft Excel.


Подключение компонентов расширения (плагинов).

NDemia CashMatic KioskBrowser - продукт, открытый для широкой интеграции со сторонним кодом. Прикладной разработчик с минимальным опытом COM-программирования может "прикрепить" к программе собственные компоненты, которые будут оповещаться обо всех событиях терминала, способны управлять терминалом так же, как и скрипты, а также способны взаимодействовать со скриптами. Причём в отличие от скриптов, работающих в контексте текущего веб-документа, компоненты расширения работают в контексте хост-приложения, т.е. их работа не прерывается и не зависит от переходов браузера со страницы на страницу, даже при отказах оборудования.


Обновление продукта.

NDemia CashMatic KioskBrowser имеет встроенный механизм проверки наличия обновлений программного продукта на сайте "ООО НДемиа", что позволяет владельцу терминала всегда иметь самую свежую версию программного продукта.


Испытательный срок.

Средства лицензирования программного продукта NDemia CashMatic KioskBrowser обеспечивают пользователям возможность бесплатного использования программы в полном объёме в течение испытательного срока, без каких-либо функциональных ограничений.


Состав.

В стандартную комплектацию программного продукта NDemia CashMatic KioskBrowser входят следующие компоненты:
  • Пользовательский графический интерфейс KioskBrowser.exe (основное приложение);
  • Панель управления NDemia CashMatic (CMControl.exe);
  • Апплет панели задач Windows (CMStartApp.exe);
  • Программа регистрации программного продукта и активации лицензионного ключа (CMRegUI.exe)
  • Служба NDemia CashMatic Kiosk и её интерфейсные команды (CMKiosk.exe и др.)
  • Деинсталлятор (Uninstall.exe)
  • Гипертекстная документация: Руководство прикладного программиста (CashMatic.chm) и Руководство по эксплуатации (UserGuide.chm);
  • Пример полнофункционального платёжного интерфейса, включающий в себя шаблоны чеков разной степени сложности;
  • Файлы настройки системы команд для разных моделей чековых принтеров.


Поддерживаемое оборудование.

NDemia CashMatic KioskBrowser поддерживает работу следующих типов оборудования:
купюроприёмник, работающий по протоколу CCNET (CashCode) или ICT004;
чековый принтер, работающий через COM-порт (RS232) - любая модель, для которой известна система команд (в стандартной комплектации текущей версии имеются готовые настройки для принтеров Citizen CBM1000, Citizen PPU700, Custom VKP80, Star TUP900, SysFuture AV268, при наличии документации на принтер с помощью Панели управления NDemia CashMatic можно достаточно легко описать систему команд любого другого принтера, в той или иной степени поддерживающего стандарт ESC/P);
фискальный регистратор производства "Штрих-М" (любая модель, поддерживаемая драйвером «Штрих-М: Драйвер ФР» - см. http://www.shtrih-m.ru).


Системные требования.

Для работы NDemia CashMatic KioskBrowser требуется:

компьютер (или терминал), работающий под управлением Microsoft Windows версии не ниже Windows 2000. Базовой системой для NDemia CashMatic является Windows XP, гарантируется поддержка Windows Vista и Windows 7, использование других версий может потребовать дополнительного сопровождения. На компьютере (терминале) должен быть установлен Microsoft Internet Explorer v.6 или Windows Internet Explorer v.7 и выше.
соединение с интернетом (как минимум, на время регистрации программного продукта, активации лицензионного ключа и проверки обновлений) - хотя бы сеансовое низкоскоростное.


Профессиональные требования.

Установка и экслуатация;
Разработка.


Установка и экслуатация.

Для установки и эксплуатации программного продукта NDemia CashMatic KioskBrowser достаточно общей компьютерной грамотности:
умение устанавливать и удалять программы;
умение находить, открывать, копировать и переименовывать папки и файлы на диске компьтера;
понимание вопросов подключения и настройки COM-портов (RS232) - хотя бы в общих чертах;
владение командной строкой и редактором реестра желательно, но в общем не обязательно.


Разработка.

Программный продукт NDemia CashMatic KioskBrowser по своему назначению заранее предполагает необходимость доработки под конкретные задачи его покупателей. Поэтому кроме уровня установки и эксплуатации рассматривается уровень разработки.
Для разработки прикладных систем на основе NDemia CashMatic KioskBrowser требуется:
владение HTML хотя бы в общих чертах;
владение javascript или Visual Basic в рамках программирования для Internet Explorer;
умение читать гипертекстную техническую документацию;
владение PHP или другой технологией программирования серверной стороны для NDemia CashMatic непосредственно не требуется, но предполагается, что разработчик системы в целом такими знаниями должен обладать.


Как установить.

Для того, чтобы установить программный продукт NDemia CashMatic KioskBrowser на Ваш компьютер, Вам нужно получить установочный файл (инсталлятор) Install.CashMatic.exe. (текущий выпуск можно скачать по адресу http://www.ndemia.com/CashMatic/download)
Установку программы на компьютер может выполнить только пользователь с правами локального администратора. (примечание: для основного приложения NDemia CashMatic KioskBrowser желательна установка в профиле устанавливающего пользователя, поэтому, если устанавливающий пользователь не является администратором, то рекомендуется не установка от другого имени, а повышение прав пользователю до администратора на время установки. При работе права администратора требуются только для настройки подключения оборудования в Панели управления NDemia CashMatic)

Запустите Install.CashMatic.exe.
Ознакомьтесь с текстом Лицензионного Соглашения, фактом установки программы Вы подтверждаете его с Вашей стороны.
По окончании распаковки и копирования файлов запустится Панель управления NDemia CashMatic.
На страницах "Купюроприёмник" и "Принтер" проверьте параметры подключения оборудования Вашего платёжного киоска. Если оборудование физически подключено, Вы можете проверить наличие связи. Все элементы управления снабжены всплывающими подсказками (по кнопке "?").

На странице "Лицензия" в поле "Состояние лицензии" Вы можете узнать и в дальнейшем отслеживать состояние Вашей лицензии. При самой первой установке NDemia CashMatic KioskBrowser на компьютер или терминал требуется выполнить регистрацию программного продукта (или активацию лицензионного ключа, если Вы его уже приобрели). Для этого в Панели управления NDemia CashMatic нажмите кнопку "Регистрация продукта и активация ключа", и следуйте инструкциям, выдаваемым программным обеспечением на экран (подключение купюроприёмника желательно настроить и проверить до регистрации или активации).

После выполнения регистрации программного продукта Вы можете испытывать его в полнофункциональном режиме в течение всего испытательного срока.
Более подробные сведения о регистрации программного продукта (и возможных проблемах, которые могут при этом встретиться) приведены в "Руководстве по эксплуатации" в разделе "Регистрация".


Лицензирование.

При установке NDemia CashMatic KioskBrowser заключается Лицензионное Соглашение между устанавливающим пользователем и ООО НДемиа (правообладателем исключительных имущественных прав на программный продукт).
Лицензионное Соглашение даёт право использовать NDemia CashMatic KioskBrowser на одном терминале.
После установки в ходе регистрации программного продукта средствами лицензирования NDemia CashMatic выполняется привязка продукта к оборудованию и операционной системе компьютера или терминала, на котором продукт будет использоваться. В случае использования купюроприёмника с протоколом управления CCNET (CashCode) выполняется также привязка к идентификационным данным купюроприёмника.
Лицензионное Соглашение не предоставляет право собственности на программный продукт и его компоненты, а только право использования продукта и его компонентов в соответствии с условиями, которые обозначены в тексте Соглашения.
Учёт использования программного продукта в значительной степени автоматизирован и осуществляется путём выполнения пользователем определённых учётных процедур: регистрации программного продукта и активации лицензионного ключа.
Пользователь имеет право создавать и распространять собственные разработки, созданные на основе программного продукта и требующие его использования. Пользователь имеет право передавать программный продукт другим лицам во временное использование в составе платёжного терминала, на котором установлен программный продукт.
Более подробно см. текст Лицензионного Соглашения, предъявляемый при установке программного продукта.


Документация.

В стандартную комплектацию программного продукта NDemia CashMatic KioskBrowser включены два подробных гипертекстных руководства:
  • Руководство по эксплуатации (файл UserGuide.chm) - предназначено для персонала, выполняющего установку и ежедневную эксплуатацию программного продукта;
  • Руководство прикладного программиста (файл CashMatic.chm) - предназначено для разработчика прикладной платёжной системы, использующей в качестве пользовательского интерфейса NDemia CashMatic KioskBrowser.

Кроме того, программная документация включает пример готового полнофункционального платёжного интерфейса (набор тщательно откомментированных HTML-файлов), а также несколько примеров шаблонов чеков на языке описания шаблонов печати NDemia CashMatic.


Поддержка.

Техническая поддержка программного продукта предусматривает устранение ошибок, консультации пользователей по электронной почте, распространение обновлений программного продукта через интернет.


Как купить.

Перед приобретением платной лицензии рекомендуется скачать и установить программный продукт NDemia CashMatic KioskBrowser на бесплатный испытательный срок.
Программный продукт продаётся только на территории Российской Федерации, только юридическим лицам по безналичному расчёту.
Цена лицензии на один терминал: 6490 руб., включая НДС.
Если Вы приняли положительное решение о покупке, напишите письмо по адресу ndemia@ndemia.com, для ускорения процесса укажите:
  • интересующее Вас количество экземпляров программного продукта;
  • полные реквизиты Вашего предприятия, включая почтовый адрес (для обычной почты);
  • контактное лицо (и желательно телефон контактного лица).

В ответ Вам будут высланы в электронном виде счёт на оплату и договор. Если Вас устраивают условия договора, то оплатите счёт (и обязательно сообщите об оплате счёта электронным письмом).
Как только средства поступят на расчётный счёт ООО НДемиа, Вам будут высланы:
  • в электронном виде:
    • лицензионные ключи (в соответствии с приобретаемым количеством лицензий);
  • в бумажном виде (обычной почтой):
    • оригинал счёта;
    • договор, подписанный со стороны ООО НДемиа (2 экземпляра);
    • счёт-фактура;
    • акт приёма-передачи программного продукта (2 экземпляра);
    • бумажная Лицензия (по одному экземпляру на каждый лицензионный ключ).

По получении бумажных документов Ваша сторона подписывает договор и акт, и отправляет документы на почтовый адрес ООО НДемиа.


Скриншоты.

Пример платёжного интерфейса;
Разработки наших пользователей.


Пример платёжного интерфейса.

Пример платёжного интерфейса, поставляемый в стандартной комплектации программного продукта:
Стартовый экран;
Экран ввода информации о платеже;
Экран приёма наличных;
Экран завершения платежа.


Стартовый экран.


Экран ввода информации о платеже.

В примере на этой странице делается выбор шаблона чека - конечно, не предлагается такой выбор предоставлять конечному пользователю-плательщику, здесь это показано только для демонстрации некоторых возможностей скриптов.


Экран приёма наличных.


Экран завершения платежа.


Разработки наших пользователей.

  • CYBERKASSA - прислал Аданцов Евгений, ООО Еврософт (г. Ставрополь), argus1978@mail.ru;
  • ЮГРАСЕРВИСС - прислал Волин Андрей, ЮГРАСЕРВИСС (г. Нижневартовск), http://forum.ndemia.com/user-reg.php?profile=ugraserviss;
  • UltraPayMax - прислал Олег Ющенко, г. Одесса, oleg-yu@ukr.net;
  • MONNET - прислал Белоконь Виктор, ОАО "Монтаж" (г. Дзержинский Московской обл.), http://www.monnet.ru, ats550@monnet.ru, http://forum.ndemia.com/user-reg.php?profile=monnet.


CYBERKASSA.

Платёжный интерфейс, работающий на платформе NDemia CashMatic KioskBrowser (прислал Аданцов Евгений, ООО Еврософт, г. Ставрополь, argus1978@mail.ru).


ЮГРАСЕРВИСС.

Платёжный интерфейс, работающий на платформе NDemia CashMatic KioskBrowser (заказная сборка M7) (прислал Волин Андрей, ЮГРАСЕРВИСС, г. Нижневартовск, http://forum.ndemia.com/user-reg.php?profile=ugraserviss).


UltraPayMax.

Платёжный интерфейс, работающий на платформе NDemia CashMatic KioskBrowser (прислал Олег Ющенко, г. Одесса, oleg-yu@ukr.net).


MONNET.

Платёжный интерфейс, работающий на платформе NDemia CashMatic KioskBrowser (прислал Белоконь Виктор, ОАО "Монтаж", г. Дзержинский Московской обл., http://www.monnet.ru, ats550@monnet.ru, http://forum.ndemia.com/user-reg.php?profile=monnet).


NDemia CashMatic KioskBrowser. Обзор программного продукта.

NDemia CashMatic KioskBrowser.
Обзор программного продукта.

Назначение Возможности Состав Поддерживаемое оборудование Системные требования Профессиональные требования Как установить Лицензирование Документация Поддержка Как купить Скриншоты